главнаяреклама на сайтезаработоксотрудничество База знаний Allbest
 
 
Сколько стоит заказать работу?   Искать с помощью Google и Яндекса
 


Применение пакетов прикладных программ в расчетах на ЭВМ

Описание стандартных функций и процедур MS Excel и MathCad, используемых при выполнении задания. Математическая постановка задачи и описание математического метода, используемого для решения задачи. Изображение алгоритма решения математической задачи.

Рубрика: Коммуникации, связь, цифровые приборы и радиоэлектроника
Вид: курсовая работа
Язык: русский
Дата добавления: 22.04.2009
Размер файла: 780,2 K

Полная информация о работе Полная информация о работе
Скачать работу можно здесь Скачать работу можно здесь

рекомендуем


Отправить свою хорошую работу в базу знаний просто. Используйте форму, расположенную ниже.

Название работы:
E-mail (не обязательно):
Ваше имя или ник:
Файл:


Cтуденты, аспиранты, молодые ученые, использующие базу знаний в своей учебе и работе, будут вам очень благодарны

Подобные работы


1. Разработка математической модели электронного устройства
Расчет переходного процесса на основе численных методов решения дифференциальных уравнений. Разработка математической модели и решение с использованием метода пространства состояний. Составление математической модели с помощью матрично-векторного метода.
курсовая работа [161,1 K], добавлена 14.06.2010

2. Оценка надежности радиоэлектронного устройства с учетом внезапных отказов путем моделирования на ЭВМ отказов элементов
Среднее время и вероятность безотказной работы. Гамма-процентная наработка до отказа. Краткое описание метода моделирования на ЭВМ отказов элементов. Решение задачи на ЭВМ и описание используемых операторов. Аналитический расчет показателей надежности.
курсовая работа [38,9 K], добавлена 12.06.2010

3. Измерения параметров сигнала. Структура оптимального измерителя
Сущность, условия решения и критерий оптимальности задачи измерения параметров сигнала. Постановка задачи измерения параметров сигнала. Классификация измерителей. Следящий режим измерения. Автоматические измерители работающие без участия человека.
реферат [382,0 K], добавлена 29.01.2009

4. Разработка печатного модуля РЭС с использованием учебных алгоритмов САПР
Решение задачи компоновки для функциональной схемы с использованием последовательного алгоритма, пошаговое описание алгоритма. Размещение элементов в принципиальной электрической схеме. Трассировка цепей питания и земли с помощью волновых алгоритмов.
курсовая работа [1,1 M], добавлена 19.06.2010

5. Методы оценки качества функционирования систем распределения информации
Теория телетрафика как научное направление: основные задачи, историческое развитие, математические модели систем распределения информации. Общие методы решения прикладных задач, примеры. Расчет величины возникающей на цифровой АТС нагрузки от абонентов.
курсовая работа [69,5 K], добавлена 15.11.2013

6. Расчет и построение АЧХ фильтра и его структурной схемы
Формулировка требований к частотным характеристикам фильтра. Определение передаточной функции. Исходные данные для решения аппроксимационной задачи. Краткий обзор методов решения. Типы аналоговых фильтров. Структурная схема разработанного устройства.
курсовая работа [346,3 K], добавлена 20.11.2013

7. Модернизация алгоритма распознания цели многофункциональной РЛС
Возможность выделения сигнальных признаков в приемниках обнаружения и сопровождения. Технические характеристики и аналитическое описание сигналов. Подбор математической модели алгоритма радиолокационного распознавания. Разработка программного продукта.
курсовая работа [415,8 K], добавлена 23.09.2011

8. Разработка авторского звукового решения
Роль звукорежиссера, его задачи и функции в создании кино-видео фильма. Художественно-технические особенности работы и их реализация. Создание звукового решения и экспликация. Монтаж фонограмм и подготовка проекта к перезаписи. Используемое оборудование.
дипломная работа [793,0 K], добавлена 19.02.2013

9. Автоматизированное проектирование аналоговых фильтров
Постановка задачи расчета активных аналоговых фильтров на резистивно-емкостных радиоэлементах. Нормирование характеристик и электрических величин. Каскадная реализация фильтра по передаточной функции. Описание программы, реализующей методику расчета.
курсовая работа [302,6 K], добавлена 28.10.2011

10. Устройство контроля за уровнем аналоговых сигналов
Детализация исходного ТЗ и постановка задачи (использование блочно-иерархического подхода при разработке устройства контроля за уровнем аналоговых сигналов). Структурная схема, её описание. Расчет потребляемой мощности и требования к источникам питания.
курсовая работа [119,3 K], добавлена 14.02.2009


Другие работы, подобные Применение пакетов прикладных программ в расчетах на ЭВМ


3

ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ

РОССИЙСКОЙ ФЕДЕРАЦИИ

Допущена к защите «__» _________ 2007 г.

Руководитель __________________

КУРСОВАЯ РАБОТА

По дисциплине «Информатика»

«Применение пакетов прикладных программ в расчетах на ЭВМ»

Работу выполнил студент

Вариант №4

Курсовая работа защищена с оценкой ___

Дата защиты «__» _________ 2007 г.

Руководитель _____________

Орел 2007

Оглавление

Задание на курсовую работу

Задание №1

Задание №2

Задание №3

Задание №4

Задание №5

Список использованных источников

Задание на курсовую работу

Студент Есипов А.О. Группа 11-П. Вариант №4.

I. Выполнить задания 1-5.

1.Написать реферат на тему «Программы обработки изображений. Основные принципы их работы».

2. Решить общую (экономическую) задачу в MS Excel. Составить таблицу, записать составленные формулы и построить диаграмму. Тип диаграммы: кольцевая. Исходные данные для построения диаграммы: данные столбца Количество относительно данных столбца Код. Легенда: данные столбца Код. Значения областей диаграммы должны быть выражены в процентах.

К=86%. Р=574 руб. R=29%.

3.Решить математическую задачу в MS Excel и MathCad.

а) Решить систему линейных уравнений А-1АТА АТА-1 X=B и вычислить значение квадратичной формы Z=YTAATA4ATY, где

; ;

б) При исследовании некоторой характеристики прибора установлена некоторая зависимость одного показателя Y этого прибора от другого показателя X. Результаты исследования представлены в таблице. Используя метод наименьших квадратов, построить линейную модель Y=б01X.

4.Вычислить значение функции с шагом h = 0,45 и построить в одной системе координат при графики следующих функций

;

используя MS Excel и MathCad.

5.Разработать алгоритм решения задачи и изобразить его в виде

блок-схемы.

Даны натуральное число k, одномерный действительный массив А порядка k. Переписать массив А в массив В в порядке возрастания значения элементов.

II.Оформить записку к курсовой работе в MS Word. Записка должна представлять собой Esipo.doc - файл, включающий

1) Титульный лист курсовой работы.

2) Оглавление, созданное средствами MS Word по созданию оглавлений.

3) Здание на курсовую работу.

4)Реферат на тему «Программы обработки изображений. Основные принципы их работы».

4.1. Лист с заданием №1 и планом реферата.

4.2. Текст реферата со ссылками на используемые источники.

4.3. Список используемых источников (не менее трех).

5)Решить общую (экономическую) задачу в MS Excel.

5.1. Лист с заданием №2 и краткое описание среды, в которой выполняется задание (MS Excel).

5.2. Описание функций, используемых при решении задания (синтаксис команд, для чего используются команды).

5.3.Текстовое описание заполнения таблицы.

5.4. Расчетная таблица на 1 - 2 страницах.

5.5. Таблица из пункта 5.4 в формульном виде.

5.6.Диаграмма.

6) Решение математической задачи в MS Excel в системе MathCad.

6.1. Лист с заданием №3.

6.2. Математическая постановка задачи и описание математического метода, используемого для решения этой задачи.

6.3. Описание стандартных функций и процедур MS Excel и MathCad, используемых при выполнении задания.

6.4. Листинг выполнения задания в MS Excel (все таблицы представляются в расчетном и формульном виде).

6.5. Листинг выполнения задания в MathCad.

Пункты 6.2 - 6.5 выполнить для а) и б) отдельно.

7) Вычисление значений функций и построение их графиков в одной системе координат.

7.1. Лист с заданием №4.

7.2. Описание стандартных функций и процедур MS Excel и MathCad, используемых при выполнении задания.

7.3. Листинг выполнения задания в MS Excel (все таблицы представляются в расчетном и формульном виде).

7.4. Листинг выполнения задания в MathCad.

8) Изображение алгоритма решения математической задачи в виде блок-схемы.

8.1. Лист с заданием №5.

8.2. Описание алгоритмических схем, реализованных при выполнении предложенного задания.

8.3. Построенная блок-схема, выполненная с MS Word.

9) Список используемых источников, оформленный в соответствии с ГОСТ 7.1 - 2003.

III. В верхнем левом углу, начиная с третьей страницы, проставляется колонтитул, который должен содержать: фамилию и инициалы, номер группы и номер варианта.

Страницы записки нумеруются в верхнем правом углу. Номера страниц на титульном листе и листе оглавления не проставляются. На странице «Задание на курсовую работу …» указывается страница №3, далее страницы 4, 5, 6 и т.д.

В строках оглавления номера страниц показываются по правому краю, заполнитель - любой.

Записка сдается на проверку в виде файла на дискете «3,5» (дюйма) (дискета вкладывается в файл-папку) и на бумажном носителе на листах формата А4, скрепленных между собой.

Печать документа выполняется с одной стороны листа. Гарнитура шрифта Times New Roman. Размер шрифта 14 пт. Межстрочный интервал - полуторный. Размер шрифта колонтитула - 10 пт. Поля: верхнее и нижнее - 20 мм, левое - 30 мм, правое - 15-20 мм.

Все формулы должны быть набраны, используя редактор формул, например MS Equation.

Работа должна быть представлена на проверку не позднее 3 мая 2007 г.

Если работа возвращается после проверки без допуска к защите (с замечаниями), то после внесения изменений записка сдается на повторную проверку. Страницы, которые были заменены при корректировке работы, прикладываются к записке и сдаются вместе с запиской на повторную проверку.

Задание выдано 28 февраля 2007 г.

Руководитель Ноздрунов В.В.

Студент Есипов А.О.

Задание №1

Написать реферат на тему «Программы обработки изображений. Основные принципы их работы».

Содержание:

Введение

Виды графических редакторов

Векторные графические редакторы

Растровые графические редакторы

Заключение

Введение

Представление данных на мониторе компьютера в графическом виде впервые было реализовано в середине 50-х годов для больших ЭВМ, применявшихся в научных и военных исследованиях. С тех пор графический способ отображения данных стал неотъемлемой частью подавляющего числа компьютерных систем, в особенности персональных.

Компьютерная графика-это специальная область информатики, изучающая методы и средства создания и обработки изображений с помощью программно-аппаратных вычислительных комплексов. Она охватывает все виды и формы представления изображений, доступных для восприятия человеком либо на экране монитора, либо в виде копии на внешнем носителе (бумага, киноплёнка, ткань и прочее).

Без компьютерной графики невозможно представить себе не только компьютерный, но и обычный, вполне материальный мир. На сегодняшний день компьютеры и компьютерная графика неотъемлемая часть жизни современного общества. Для примера назовём медицину (компьютерная томография), научные исследования (визуализация строения вещества, векторных полей и других данных), моделирование тканей и одежды, опытно-конструкторские разработки, рекламные щиты, цветные журналы, спецэффекты в фильмах - всё это в той или иной мере имеет отношение к компьютерной графике. Поэтому созданы программы для создания и редактирования изображений, то есть графические редакторы.

Виды графических редакторов

Для обработки изображений на компьютере используются специальные программы - графические редакторы. Графический редактор - это программа создания, редактирования и просмотра графических изображений.

Рассмотрим некоторые из графических редакторов:

1)Графический редактор Paint -- простой однооконный графический редактор, который позволяет создавать и редактировать достаточно сложные рисунки.

2)Photoshop фирмы Adobe многооконный графический редактор позволяет создавать и редактировать сложные рисунки, а также обрабатывать графические изображения (фотографии). Содержит множество фильтров для обработки фотографий (изменение яркости, контрастности и т.д.).

3)Программа Microsoft Draw -- входящая в комплект MS Office. Эта программа служит для создания различных рисунков, схем. Обычно вызывается из MS Word.

4)Adobe Illustrator, Corel Draw -- программы используются в издательском деле, позволяет создавать сложные векторные изображения.

Изображения в графических редакторах хранятся по-разному.

Растровое изображение хранится с помощью точек различного цвета (пикселей), которые образуют строки и столбцы. Любой пиксель имеет фиксированное положение и цвет. Хранение каждого пикселя требует некоторого количества бит информации, которое зависит от количества цветов в изображении.

Векторные изображения формируются из объектов (точка, линия, окружность и т. д.), которые хранятся в памяти компьютера в виде графических примитивов и описывающих их математических формул.

Например, графический примитив точка задается своими координатами (X, У), линия - координатами начала (XI, Y1) и конца (Х2, Y2), окружность - координатами центра (X, У) и радиусом (R), прямоугольник - величиной сторон и координатами левого верхнего угла (XI, У1) и правого нижнего угла (Х2, У2) и т. д. Для каждого примитива назначается также цвет.

Как следствие, графические редакторы подразделяются на две категории: растровые и векторные. Они отличаются по способу, которым представляют графическую информацию.

Векторные графические редакторы

Векторные графические изображения являются оптимальным средством для хранения высокоточных графических объектов (чертежи, схемы и т. д.), для которых имеет значение наличие четких и ясных контуров. С векторной графикой вы сталкиваетесь, когда работаете с системами компьютерного черчения и автоматизированного проектирования, с программами обработки трехмерной графики. Все компоненты векторного изображения описываются математически, а значит - абсолютно точно. Векторные изображения, как правило, строятся вручную, однако в некоторых случаях они могут быть также получены из растровых с помощью программ трассировки. Векторные изображения не в состоянии обеспечить близкую к оригиналу реалистичность, но достоинством векторной графики является то, что файлы, хранящие векторные графические изображения, имеют сравнительно небольшой объем. Важно также, что векторные графические изображения могут быть увеличены или уменьшены без потери качества.

Растровые графические редакторы.

Растровые графические редакторы являются наилучшим средством обработки фотографий и рисунков, поскольку растровые изображения обеспечивают высокую точность передачи градаций цветов и полутонов. Способ представления растровых изображений совершенно отличен от векторных. Растровые изображения состоят из отдельных точек, называемых растром. Такое представление изображений существует не только в цифровом виде. Растровые изображения обеспечивают максимальную реалистичность, поскольку в цифровую форму переводится каждый мельчайший фрагмент оригинала. Такие изображения сохраняются в файлах гораздо большего объёма, чем векторные, поскольку в них запоминается информация о каждом пикселе изображения. Таким образом, качество растровых изображений зависит от их размера (числа пикселей по горизонтали и вертикали) и количества цветов, которые могут принимать пиксели. Как следствие того, что они состоят из пикселей фиксированного размера, свободное масштабирование без потери качества к ним не применимо. Эта особенность, а также сама структура растровых изображений несколько затрудняет их редактирование и обработку.

Заключение

В результате данной работы была раскрыта тема «Программы обработки изображений. Основные принципы их работы». В данном реферате были кратко описаны виды графических редакторов, их возможности, принципиальные отличия векторных и растровых изображений. Также было выяснено, каким видом редактора лучше пользоваться для представления конкретного изображения. Но, все-таки, из-за небольшого объема работы некоторые моменты были опущены, поэтому для наиболее полного изучения данной темы следует обратиться к источникам, которые указаны ниже.

СПИСОК ИСПОЛЬЗОВАННОЙ ЛИТЕРАТУРЫ

1. Борисов, Н.Н.Форматы графических файлов[Текст]/ Н.Н. Борисов. - СПб., 2003. - 452 с.

2. Грабалов, П.К. Компьютерная графика и основные графические редакторы [Текст]/ П.К. Грабалов. - Калининград,2003. - 628 с.

3. Могилёв, А.В. Практикум по информатике[Текст]/ А.В.Могилёв. -- М.: Издательский центр «Академия», 2004.--746с.

Задание №2

Решить общую (экономическую) задачу в MS Excel. Составить таблицу, записать составленные формулы и построить диаграмму. Тип диаграммы: кольцевая. Исходные данные для построения диаграммы: данные столбца Количество относительно данных столбца Код. Легенда: данные столбца Код. Значения областей диаграммы должны быть выражены в процентах. К=86%. Р=574 руб. R=29%.

Краткое описание MS-Excel

Электронные таблицы позволяют обрабатывать большие массивы числовых данных. Наибольшее распространение получили электронные таблицы MS-Excel. Электронная таблица - это работающее в диалоговом режиме приложение, обрабатывающее и хранящее данные в прямоугольных таблицах. Она состоит из столбцов и строк, заголовки столбцов обозначаются буквами, заголовки строк - числами. Ячейка - место пересечения строки и столбца, она имеет свой собственный адрес, состоящий из заголовка строки и столбца.

Электронные таблицы, с которыми работает пользователь в приложении, называются рабочими листами.

В работе с MS-Excel можно выделить 3 основных типа данных: число, текст, формула. В зависимости от решаемой задачи возникает необходимость применять различные форматы представления данных. Для представления данных также можно использовать специализированные форматы: денежный, дата, время и др.

В MS-Excel существуют различные возможности по форматированию текста, ячеек, строк, столбцов.

MS-Excel имеет большое количество встроенных функций, которые подразделяются на категории: Математические, Статистические, Финансовые и др. MS-Excel позволяет осуществлять сортировку данных, поиск данных в соответствии с заданными условиями, позволяет визуализировать данные в виде диаграммы или графика. Диаграммы могут быть различных типов и соответственно представлять данные в различной форме.

Описание функций используемых при решении общей (экономической) задачи в MS-Excel

СУММ - суммирует все числа в интервале ячеек.

Синтаксис:

СУММ (число1;число2; ...), где число1, число2,... -- от 1 до 30 аргументов, для которых требуется определить итог или сумму.

СЧЕТЕСЛИ - подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Синтаксис:

СЧЁТЕСЛИ(диапазон; критерий), где диапазон -- диапазон, в котором нужно подсчитать ячейки, критерий -- критерий в форме числа, выражения или текста, который определяет, какие ячейки надо подсчитывать.

ЕСЛИ - возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ. Функция ЕСЛИ используется при проверке условий для значений и формул.

Синтаксис:

ЕСЛИ (лог_выражение;значение_если_истина;значение_если_ ложь).Лог_выражение -- это любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Значение_если_истина -- это значение, которое возвращается, если лог_выражение равно ИСТИНА.

Значение_если_ложь -- это значение, которое возвращается, если лог_выражение равно ЛОЖЬ.

МИН - возвращает наименьшее значение в списке аргументов. Синтаксис:

МИН (число1;число2; ...), где число1, число2,... -- от 1 до 30 чисел, среди которых требуется найти наименьшее.

МАКС - Возвращает наибольшее значение из набора значений. Синтаксис:

МАКС (число1;число2; ...), где число1, число2,... -- от 1 до 30 чисел, среди которых требуется найти наибольшее.

СРЗНАЧ - Возвращает среднее (арифметическое) своих аргументов. Синтаксис:

СРЗНАЧ(число1; число2; ...), где число1, число2, ... -- это от 1 до 30 аргументов, для которых вычисляется среднее.

Текстовое описание заполнения таблицы

Каждый студент самостоятельно заносит значения в ячейки под заголовками столбцов: «Код» (4 цифры), «Наименование изделия», «Единицы измерения», «№ счета» (3 цифры), «Продавец», «Адрес» (город, улица, дом, офис), «Количество», «Цена». Остальные ячейки являются расчетными, включая и итоговую строку.

Расчетные ячейки.

1) Ячейки столбца «Доход» рассчитываются как произведение ячеек столбца «Цена» и ячеек столбца «Количество».

2) Ячейки столбца «Расход»- это 86% от ячеек столбца «Доход».

3) Ячейки столбца «Прибыль» рассчитываются как разность ячеек столбца «Доход» и «Расход».

4) Ячейки столбца «Реклама» принимают значение «да», если значения ячеек под столбцом «Количество» больше или равно 80 «Прибыль» не меньше 700 руб., иначе «нет».

5) Значения ячеек столбца «Расходы на рекламу» принимаются равным 574 руб., если соседние ячейки под столбцом «Реклама» имеют «да», иначе 29% от минимального значения, содержащегося в столбцах «Расход» и «Прибыль» расчетной строки.

6) Ячейки столбца «Сумма» рассчитываются как сумма ячеек столбца «Прибыль» и ячеек столбца «Расхода на рекламу».

7) Ячейки строки «Итого» рассчитываются как сумма ячеек соответствующих столбцов, за исключением ячеек столбца «Реклама», в которой должно содержаться число, выражающее количество ячеек, принимающих значение «нет» в столбце «Реклама» и столбца «Цена», в котором указывается средняя цена изделий.

8) Ячейки строк «Минимальный элемент» и «Максимальный элемент» рассчитываются соответственно, как минимальное и максимальное значение ячеек соответствующих столбцов, кроме столбца «Реклама», в котором ставится прочерк.

9) Во всех указанных ячейках расчет производится, используя встроенные функции MS-Excel.

10) При составлении таблицы необходимо: заполнить данными не менее 15-20 строк; в качестве наименования изделий указать приборы, приспособления, материалы, с которыми вы будете иметь дело в своей будущей профессии; среди ячеек «Количество» должно присутствовать не менее 5 ячеек с количеством большим или равным 80 единиц и не менее 5 ячеек с количеством менее 80; данные ячеек «Количество» и «Цена» должны быть подобраны так, чтобы среди ячеек столбца «Реклама» не менее 5 ячеек имели значение «да» и не менее 5 ячеек имели значение «нет»; наименование таблицы выполнить полужирным подчеркнутым шрифтом методом объединения ячеек по центру; шапка таблицы, строки «Итого», «Минимальный элемент», «Максимальный элемент» должны быть выделены жирным обрамлением каждая в отдельности; заголовки столбцов «Изделия», «Реквизиты продавца», «Расчеты», «Издержки на рекламу», «Сумма» должны быть оформлены методом объединения ячеек с центрированием по вертикали и горизонтали; ячейки под заголовками столбцов «Цена», «Доход», «Расход», «Прибыль», «Расход на рекламу», «Сумма» должны иметь денежный формат с числом знаков после запятой 2 и обозначением «р.»; ячейки под заголовками столбцов «Код», «№ счета», «Количество» должны иметь числовой формат, причем ячейки под заголовками столбца «Количество» должны быть отцентрированы по горизонтали; остальные ячейки должны иметь текстовый формат; Ячейки, содержащие слова «Итого», «Минимальный элемент» и «Максимальный элемент» должны быть оформлены методом объединения ячеек с выравниванием по правому краю.

После создания таблицы с расчетными значениями, необходимо привести таблицу с формулами.

На диаграмме обязательно должно присутствовать ее название, название осей диаграммы, легенда.

Задание №3

Решить математическую задачу в MS Excel и MathCad.

а) Решить систему линейных уравнений А-1АТА АТА-1 X=B и вычислить значение квадратичной формы Z=YTAATA4ATY, где

; ;

б) При исследовании некоторой характеристики прибора установлена некоторая зависимость одного показателя Y этого прибора от другого показателя X. Результаты исследования представлены в таблице. Используя метод наименьших квадратов, построить линейную модель Y=б01X.

X

0,1

0,2

0,4

0,6

0,8

1

1,2

1,4

Y

3

4,38

6,78

9,86

14,96

22,07

33,17

49,23

а) 1. Решением уравнения А-1АТА АТА-1 X=B будет являться

X= АА-T А-1А-TА B

Решение в MS Excel

3

5

7

9

0

-65,90421338

5

1

4

6

5

-38,28007803

2

8

0

3

1

-7,927033742

1

1

2

5

3

-39,99174297

Решение в MathCAD

2.Z=YTAATA4ATY:

Решение в MS Excel

3

5

7

9

3

11121

14845

13349

25353

5

1

4

6

1

8194

10568

9875

18543

2

8

0

3

0

7432

8788

8367

15918

1

1

2

5

2

3698

4856

4438

8419

2625659762

В режиме проверки формул:

Решение в MathCAD

Описание функций используемых при решении математической задачи в MS-Excel

МУМНОЖ - возвращает произведение матриц (матрицы хранятся в массивах). Результатом является массив с таким же числом строк, как массив1 и с таким же числом столбцов, как массив2.

Синтаксис:

МУМНОЖ(массив1;массив2). Массив1, массив2 -- перемножаемые массивы.

МОБР - возвращает обратную матрицу для матрицы, хранящейся в массиве.

Синтаксис:

МОБР(массив)

Массив -- числовой массив с равным количеством строк и столбцов.

ТРАНСП - возвращает вертикальный диапазон ячеек в виде горизонтального и наоборот.

Синтаксис:

ТРАНСП(массив)

Массив -- это транспонируемый массив или диапазон ячеек на рабочем листе. Транспонирование массива заключается в том, что первая строка массива становится первым столбцом нового массива, вторая строка массива становится вторым столбцом нового массива и так далее.

Описание функций используемых при решении математической задачи в MathCAD

Работать с матрицами и векторами можно путем обращения к панели инструментов, необходимым пунктам основного меню или к соответствующим функциям.

Панель операций с матрицами и векторами открывается щелчком по кнопке Векторные и матричные операции на панели математических инструментов.

Для решения данной математической задачи были использованы следующие кнопки панелей Матрицы и Арифметика:

МТ - транспонирование матрицы,

X-1 - вычисление матрицы, обратной данной,

-- умножение,

XY - возведение в степень.

б) Решение в MS EXCEL

X

Y

б1

б0

0,1

3

32,51646489

-5,236731235

-1,985084746

0,2

4,38

1,266561743

0,4

6,78

7,769854722

0,6

9,86

14,2731477

0,8

14,96

20,77644068

1

22,07

27,27973366

1,2

33,17

33,78302663

1,4

49,23

40,28631961

X

Y

б1

б0

0,1

3

=ИНДЕКС(ЛИНЕЙН(B2:B9;A2:A9);1)

=ИНДЕКС(ЛИНЕЙН(B2:B9;A2:A9);2)

=$D$2+$C$2*A2

0,2

4,38

=$D$2+$C$2*A3

0,4

6,78

=$D$2+$C$2*A4

0,6

9,86

=$D$2+$C$2*A5

0,8

14,96

=$D$2+$C$2*A6

1

22,07

=$D$2+$C$2*A7

1,2

33,17

=$D$2+$C$2*A8

1,4

49,23

=$D$2+$C$2*A9

2 Решение в MathCAD.

Описание функций используемых при решении математической задачи в MS-Excel

ЛИНЕЙН - рассчитывает статистику для ряда с применением метода наименьших квадратов, чтобы вычислить прямую линию, которая наилучшим образом аппроксимирует имеющиеся данные. Функция возвращает массив, который описывает полученную прямую. Поскольку возвращается массив значений, функция должна задаваться в виде формулы массива.

Синтаксис:

ЛИНЕЙН(известные_значения_y;известные_значения_x;конст;статистика)

ИНДЕКС - Возвращает значение элемента таблицы или массива , заданного номером строки и номером столбца.

Функция ИНДЕКС имеет две синтаксические формы: ссылка и массив. Ссылочная форма всегда возвращает ссылку; форма массива всегда возвращает значение или массив значений.

Синтаксис 1:

Форма массива.

ИНДЕКС(массив;номер_строки;номер_столбца)

Массив -- это диапазон ячеек или массив констант

Синтаксис 2:

Ссылочная форма

ИНДЕКС(ссылка ;номер_строки;номер_столбца;номер_области)

Ссылка -- это ссылка на один или несколько интервалов ячеек.

Описание функций используемых при решении математической задачи в MathCAD

В системе MathCad существуют встроенные функции для вычисления коэффициентов m и b линейной зависимости y=mx+b.

slope(x,y) - коэффициент линейного уравнения регрессии m. Определяет тангенс угла наклона линии регрессии к оси x.

intercept(x,y) - свободный член уравнения регрессии b. Равен отрезку, отсекаемому линией регрессии на оси ординат.

Чтобы выполнить построение графика того или иного вида, необходимо указать его тип. Перечень основных типов графиков, предлагаемый MathCad, можно увидеть, если обратиться к пункту главного меню Вставка -> График.

Чтобы построить график в декартовых координатах в MathCAD нужно: выбрать в главном меню Вставка -> График -> X-Y Зависимость, ввести исходные данные в графическую область, заполнив маленькие прямоугольники, расположенные около осей.

Задание №4

4.Вычислить значение функции с шагом h = 0,45 и построить в одной системе координат при графики следующих функций

;

используя MS Excel и MathCad.

1)Решение в MS EXCEL:

X

F

Z

-2

-2,90107047

2,7278923

-1,55

-2,999783717

4,2632738

-1,1

-2,879371522

4,3439514

-0,65

3,578058133

3,7069872

-0,2

3,059411708

2,5859829

0,25

3,092329219

2,7265254

0,7

3,661966685

3,8061525

1,15

4,571925196

-57,9496872

1,6

5,660388679

-54,0543349

2,05

6,842696837

-57,5398959

2,5

8,077747211

-0,0010607

2,95

9,344650876

-0,0001072

3,4

10,63202709

0,0000367

3,85

11,93325186

0,0000190

4,3

13,24424403

0,0000037

X

F

Z

-2

=ЕСЛИ(A2<=-1;3*SIN(A2)-COS(A2)^2;3*КОРЕНЬ(1+A2^2))

=ЕСЛИ(A2<=1;3*ABS(SIN(A2))+КОРЕНЬ(4-A2^2);ЕСЛИ(A2>=2,5;2*EXP(-3*A2)*SIN(2*A2);2*COS(8*A2)-56))

=A2+0,45

=ЕСЛИ(A3<=-1;3*SIN(A3)-COS(A3)^2;3*КОРЕНЬ(1+A3^2))

=ЕСЛИ(A3<=1;3*ABS(SIN(A3))+КОРЕНЬ(4-A3^2);ЕСЛИ(A3>=2,5;2*EXP(-3*A3)*SIN(2*A3);2*COS(8*A3)-56))

=A3+0,45

=ЕСЛИ(A4<=-1;3*SIN(A4)-COS(A4)^2;3*КОРЕНЬ(1+A4^2))

=ЕСЛИ(A4<=1;3*ABS(SIN(A4))+КОРЕНЬ(4-A4^2);ЕСЛИ(A4>=2,5;2*EXP(-3*A4)*SIN(2*A4);2*COS(8*A4)-56))

=A4+0,45

=ЕСЛИ(A5<=-1;3*SIN(A5)-COS(A5)^2;3*КОРЕНЬ(1+A5^2))

=ЕСЛИ(A5<=1;3*ABS(SIN(A5))+КОРЕНЬ(4-A5^2);ЕСЛИ(A5>=2,5;2*EXP(-3*A5)*SIN(2*A5);2*COS(8*A5)-56))

=A5+0,45

=ЕСЛИ(A6<=-1;3*SIN(A6)-COS(A6)^2;3*КОРЕНЬ(1+A6^2))

=ЕСЛИ(A6<=1;3*ABS(SIN(A6))+КОРЕНЬ(4-A6^2);ЕСЛИ(A6>=2,5;2*EXP(-3*A6)*SIN(2*A6);2*COS(8*A6)-56))

=A6+0,45

=ЕСЛИ(A7<=-1;3*SIN(A7)-COS(A7)^2;3*КОРЕНЬ(1+A7^2))

=ЕСЛИ(A7<=1;3*ABS(SIN(A7))+КОРЕНЬ(4-A7^2);ЕСЛИ(A7>=2,5;2*EXP(-3*A7)*SIN(2*A7);2*COS(8*A7)-56))

=A7+0,45

=ЕСЛИ(A8<=-1;3*SIN(A8)-COS(A8)^2;3*КОРЕНЬ(1+A8^2))

=ЕСЛИ(A8<=1;3*ABS(SIN(A8))+КОРЕНЬ(4-A8^2);ЕСЛИ(A8>=2,5;2*EXP(-3*A8)*SIN(2*A8);2*COS(8*A8)-56))

=A8+0,45

=ЕСЛИ(A9<=-1;3*SIN(A9)-COS(A9)^2;3*КОРЕНЬ(1+A9^2))

=ЕСЛИ(A9<=1;3*ABS(SIN(A9))+КОРЕНЬ(4-A9^2);ЕСЛИ(A9>=2,5;2*EXP(-3*A9)*SIN(2*A9);2*COS(8*A9)-56))

=A9+0,45

=ЕСЛИ(A10<=-1;3*SIN(A10)-COS(A10)^2;3*КОРЕНЬ(1+A10^2))

=ЕСЛИ(A10<=1;3*ABS(SIN(A10))+КОРЕНЬ(4-A10^2);ЕСЛИ(A10>=2,5;2*EXP(-3*A10)*SIN(2*A10);2*COS(8*A10)-56))

=A10+0,45

=ЕСЛИ(A11<=-1;3*SIN(A11)-COS(A11)^2;3*КОРЕНЬ(1+A11^2))

=ЕСЛИ(A11<=1;3*ABS(SIN(A11))+КОРЕНЬ(4-A11^2);ЕСЛИ(A11>=2,5;2*EXP(-3*A11)*SIN(2*A11);2*COS(8*A11)-56))

=A11+0,45

=ЕСЛИ(A12<=-1;3*SIN(A12)-COS(A12)^2;3*КОРЕНЬ(1+A12^2))

=ЕСЛИ(A12<=1;3*ABS(SIN(A12))+КОРЕНЬ(4-A12^2);ЕСЛИ(A12>=2,5;2*EXP(-3*A12)*SIN(2*A12);2*COS(8*A12)-56))

=A12+0,45

=ЕСЛИ(A13<=-1;3*SIN(A13)-COS(A13)^2;3*КОРЕНЬ(1+A13^2))

=ЕСЛИ(A13<=1;3*ABS(SIN(A13))+КОРЕНЬ(4-A13^2);ЕСЛИ(A13>=2,5;2*EXP(-3*A13)*SIN(2*A13);2*COS(8*A13)-56))

=A13+0,45

=ЕСЛИ(A14<=-1;3*SIN(A14)-COS(A14)^2;3*КОРЕНЬ(1+A14^2))

=ЕСЛИ(A14<=1;3*ABS(SIN(A14))+КОРЕНЬ(4-A14^2);ЕСЛИ(A14>=2,5;2*EXP(-3*A14)*SIN(2*A14);2*COS(8*A14)-56))

=A14+0,45

=ЕСЛИ(A15<=-1;3*SIN(A15)-COS(A15)^2;3*КОРЕНЬ(1+A15^2))

=ЕСЛИ(A15<=1;3*ABS(SIN(A15))+КОРЕНЬ(4-A15^2);ЕСЛИ(A15>=2,5;2*EXP(-3*A15)*SIN(2*A15);2*COS(8*A15)-56))

=A15+0,45

=ЕСЛИ(A16<=-1;3*SIN(A16)-COS(A16)^2;3*КОРЕНЬ(1+A16^2))

=ЕСЛИ(A16<=1;3*ABS(SIN(A16))+КОРЕНЬ(4-A16^2);ЕСЛИ(A16>=2,5;2*EXP(-3*A16)*SIN(2*A16);2*COS(8*A16)-56))

Решение в MathCad:

Описание функций используемых при решении математической задачи в MS-Excel

ЕСЛИ - возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ. Функция ЕСЛИ используется при проверке условий для значений и формул.

Синтаксис:

ЕСЛИ (лог_выражение;значение_если_истина;значение_если_ ложь).Лог_выражение -- это любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Значение_если_истина -- это значение, которое возвращается, если лог_выражение равно ИСТИНА.

Значение_если_ложь -- это значение, которое возвращается, если лог_выражение равно ЛОЖЬ.

ABS - возвращает модуль (абсолютную величину) числа. Абсолютная величина числа - это число без знака.

Синтаксис:

ABS(число)

Число -- это действительное число, модуль которого требуется найти

EXP - Возвращает число «e», возведенное в указанную степень. Число «e» равно 2,71828182845904 и является основанием натурального логарифма.

Синтаксис:

EXP(число)

Число -- это число, для которого вычисляется экспоненциальная функция с основанием «e».

COS - Возвращает косинус заданного угла.

Синтаксис:

COS(число)

Число -- это угол в радианах, для которого определяется косинус.

SIN - Возвращает синус заданного угла.

Синтаксис:

SIN(число)

Число -- угол в радианах, для которого вычисляется синус.

КОРЕНЬ - Возвращает положительное значение квадратного корня.

Синтаксис:

КОРЕНЬ(число)

Число -- число, для которого вычисляется квадратный корень.

Описание функций используемых при решении математической задачи в MathCAD

Для организации разветвлений в MathCad предусмотрена функция if

Синтаксис:

if(условие,значение1,значение2)

Функция if возвращает значение1, если условие истинно (не равно 0), или значение2 в противоположном случае.

Для решения данной задачи были использованы следующие операторы:

« + » - сложение,

« - » - вычитание,

« »- умножение,

« / »- деление,

« »- извлечение квадратного корня,

« sin »-синус,

« cos »- косинус,

« XY »- возведение в степень,

« » - абсолютная величина,

«»- больше или равен,

«»- меньше или равен

« еx »- экспонента

Задание №5

Разработать алгоритм решения задачи и изобразить его в виде

блок-схемы.

Даны натуральное число k, одномерный действительный массив А порядка k. Переписать массив А в массив В в порядке возрастания значения элементов.

Список использованных источников

1.Алексеев, М.В. Информатика[Текст]/М.В. Алексеев.--М.: «Просвещение»,2003--465с. ISBN 5-7715-1290-3.

2. Евсеев, Г.А. Новейший самоучитель работы на компьютере [Текст] / Г.А. Евсеев, В.И. Мураховский, С.В. Симонович; под ред. С.В Симоновича - М.: ДЕСС КОМ, 2002. - 688 с.: ил.

3. Информатика [Текст]: Практикум по технологии работы на компьютере/ Н.В. Макарова [и др.];под ред. Н.В. Макаровой. - 3-е изд., перераб. - М.: Финансы и статистика, 2005. - 256 с.: ил. ISBN 5-279-02280-2

4.Кудрявцев, Е.М. Mathcad 11: Полное руководство по русской версии [Текст] / Е.М. Кудрявцев. - М: ДМК Пресс, 2005. - 592 с.: ил. - ISBN 5-94074-175-4

5.Могилёв, А.В. Учеб. пособие для студентов педагогических вузов [Текст]/ А.В.Могилёв, Н.И.Пак, Е.К.Хеннекер, под ред. Е.К.Хеннекера.--Изд. 3-е, перераб. и доп.--М.: Издательский центр «Академия», 2004.--848с. ISBN 5-7695-1709-3.

6.Пащенко,И.В. Excel. Шаг за шагом [Текст]/И.В. Пащенко. - М.: Эксмо,2006. - 352с. ISBN 5-699-14559-1

7.ASBUKA.com Информационный центр [Электронный ресурс]. - Режим доступа: www.asbuka.ru


Скачать работу можно здесь Скачать работу "Применение пакетов прикладных программ в расчетах на ЭВМ" можно здесь
Сколько стоит?

Рекомендуем!

база знанийглобальная сеть рефератов